Lingo for macOS is now downloading

Your download should start automatically within seconds.
If it doesn't, click here.

Requires macOS 10.10+